[OpenBlockS Users page]
[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[obu:01269] Vine on OBSS (was Re: Re: Debian on OpenBlockSS


柴田(ひ)@福岡です。

> 私の方はredhat 7.2をベースにsrc.rpmからしこしことrpmを作ってきてましたが
> さすがにつかれてきたので、最近はVineSeedのppc版に移行しています。

詳細な手順はもう書けませんが(^^;、Vine化の方法をば。
	#手抜きして書いているので、補足求む。


(1)ぷらっとさんが公開しているOBS用のrpmをOBSSにインストールする。
	#ちゃんと動きますが、
	#ソースからmakeしても良いかも。

(2)次にaptをインストールする。
	しかるべきところから apt-0.3.19.cnc.53-2vl2.ppc.rpm を
	持ってきて、rpm -ivh

(3)/etc/apt/sources.list を編集してVineSeedから持ってくるようにする。
	必須の行だけ書くと、こんな感じかな。
	rpm ftp://ftp.rpmlinux.com/vine/Vine-2.1/updates/ aptdata/ppc 1
	rpm-src ftp://ftp.rpmlinux.com/vine/Vine-2.1/updates/ aptdata/ppc 0 1
	rpm ftp://ftp.rpmlinux.com/vine/VinePlus/2.1/ aptdata/ppc 1
	rpm ftp://ftp.rpmlinux.com/vine/VinePlus/2.1/ aptdata/noarch 4
	rpm ftp://ftp.rpmlinux.com/vine/VineSeed/ aptdata/ppc 1
	rpm ftp://ftp.rpmlinux.com/vine/VineSeed/VineSeedPlus/ aptdata/ppc 1
	rpm ftp://ftp.rpmlinux.com/vine/VineSeed/VineSeedPlus/ aptdata/noarch 4

(4)apt-get update を実行。

(5)apt-get dist-upgrade を実行。
	足りないパッケージがあれこれ指摘されるので、
	ftpなどで持ってきてrpm -ivhで正しく実行されるまで繰り返す(^^;

(6)何となくupgrade出来るパッケージがなくなる(^^;;;
	ちなみに私がインストールしたものは、このメールの末尾につけます。

(7)ここでさっくりリブートしてはいけません。
	/etc/inittab /etc/rc.d/rc.sysinit /etc/rc.localをしかるべく
	編集してからではないと、リブートしてlogin出来ずに寂しくなります。
	#私は寂しくなりました(^^;
	#OBSSからディスクをはずして、別マシンでファイル編集する羽目に。

	特にOBSSの標準のrunlevelが2であるのに対して、
	Vineは3(ふつーそうかな)なので、この辺り注意が必要です。

(8)リブートさせる。
	うまく行けばVineSeedです。glibc-2.2.4も入ります。

まだ動きがおかしいところもありますが、Debianと同じくapt-getで
新しいパッケージが入るのは楽ですよ。

現在インストールしているパッケージを示します。

bdflush-1.5-14vl2
vine-release-2.1.5-1
bash-2.05-8
autoconf-2.13-14
automake-1.4p5-2
jcode.pl-2.13-2
logwatch-2.1.1-3
gawk-3.1.0-3
grep-2.4.2-7
apache-devel-1.3.22-0vl2
mktemp-1.5-11vl1
fileutils-4.1-4
pam-0.75-19
pam-devel-0.75-19
cracklib-2.7-12
cracklib-dicts-2.7-12
libtool-1.4-8
libtool-libs-1.4-8
words-2-17
binutils-2.11.90.0.8-9
bash-doc-2.05-8
bzip2-1.0.1-4
bzip2-devel-1.0.1-4
bzip2-libs-1.0.1-4
termcap-11.0.1-10
pwdb-0.61.1-3
MAKEDEV-3.2-5
zlib-1.1.3-24
zlib-devel-1.1.3-24
which-2.12-3
ucd-snmp-devel-4.2.1-7vl1
less-358-0vl6
mkinitrd-3.0.10-1vl2
tar-1.13.19-6
tcpdump-3.6.2-9
libpcap-0.6.2-9
time-1.7-14
traceroute-1.4a12-1
stat-2.2-1vl1
passwd-0.64.1-4vl1
patch-2.5.4-10
ppp-2.4.1-2
procinfo-18-2
procps-2.0.7-11
gd-1.8.4-4
gd-devel-1.8.4-4
gd-progs-1.8.4-4
libpng-1.0.12-2
libpng-devel-1.0.12-2
util-linux-2.11h-0vl4
sudo-1.6.4p1-0vl1
libtermcap-2.0.8-28
libtermcap-devel-2.0.8-28
slang-1.4.4-4
slang-devel-1.4.4-4
setserial-2.17-4
mingetty-0.9.4-17vl1
shadow-utils-20000902-4
mailcap-2.1.6-1vl1
perl-File-MMagic-1.12-0vl3
openssl-0.9.6b-8
openssl-devel-0.9.6b-8
openssl-perl-0.9.6b-8
libstdc++2_10-compat-2.10.0-0vl1
db3-devel-3.2.9-4
sed-3.02_mb1.09-0vl1
liberuby-0.9.7-0vl1
alternatives-0.1.9.17-0vl2
apt-0.3.19.cnc.53-2vl2
setup-2.2.1-1vl4
filesystem-1.3.5-1vl1
basesystem-6.0-4vl3
chkconfig-1.2.17-1vl6
glibc-common-2.2.4-14vl8
glibc-2.2.4-14vl8
db1-1.85-5vl2
db2-2.4.14-5vl2
db3-3.2.9-1vl2
gnupg-1.0.6-0vl1
info-4.0b-3vl1
libstdc++2_10-2.10.0-2vl20
modutils-2.4.12-2vl1
newt-0.50.22-0vl1
popt-1.5.1-0vl20
portmap-4.0-38vl1
textutils-2.0.11-6vl1
rpm-3.0.6-0vl20
setuptool-1.2-5vl3
kernel-smp-2.2.20-0vl6
e2fsprogs-1.25-0vl1
logrotate-3.5.4-1vl2
sysklogd-1.4-7vl3
psmisc-19-4vl1
ncurses-5.2-12vl2
tcsh-6.10.02-0vl2
initscripts-5.52-1vl10
ucd-snmp-4.2.1-7vl1
gzip-1.3.2-2vl1
rootfiles-6.2-0vl1
diffutils-2.7.2-0vl3
mount-2.11g-5vl1
libjpeg-6b-15vl1
ucd-snmp-utils-4.2.1-7vl1
glib-1.2.10-0vl3
SysVinit-2.78-10vl3
file-3.35-0vl3
losetup-2.11g-5vl1
gdbm-devel-1.8.0-10vl1
gdbm-1.8.0-10vl1
findutils-4.1.5-0vl3
rsync-2.5.1-0vl1
ncurses-devel-5.2-12vl2
console-tools-19990829-29vl2
freetype2-2.0.1-0vl5
dev-2.7.18-3vl8
ash-0.2-27vl1
gettext-0.10.35_jp-18vl1
vutils-1.18.16-0vl1
ed-0.2-19vl1
m4-1.4.1-3vl1
ncftp-3.1.1-0vl1
perl-5.6.1-0vl4
sh-utils-2.0_jp-13vl2
JF-20011115-0vl1
at-3.1.8-12vl3
apache-1.3.22-0vl2
cpio-2.4.2-20vl1
bind-8.2.5-0vl0
bind-utils-8.2.5-0vl0
gcc-c++-2.95.3-2vl20
kernel-headers-2.2.20-0vl6
glibc-devel-2.2.4-14vl8
tkinter-1.5.2-28vl3
gcc-tools-2.95.3-2vl20
fetchmailconf-5.9.6-0vl1
tix-4.1.0.6_jp-10vl3
tcl-8.0.5_jp-10vl7
eruby-0.9.7-0vl1
ftp-0.17-6vl1
expect-5.28-10vl3
gmp-2.0.2-13vl2
python-1.5.2-28vl3
readline-4.1-6vl5
gcc-2.95.3-2vl20
procmail-3.22-0vl1
XFree86-libs-3.3.6-13vl29
libruby-1.6.6-0vl4
fetchmail-5.9.6-0vl1
tk-8.0.5_jp-10vl6
postfix-0.0.20010228pl08-0vl2
gcc-cpp-2.95.3-2vl20
freetype-1.3.1-5vl2
nfs-utils-0.3.1-12vl2
make-3.79.1-5vl1
namazu-2.0.10-0vl1
openssh-3.0.2p1-0vl0
timeconfig-3.0.3-2vl4
gtk+-1.2.10-0vl3
proftpd-1.2.5-0vl1
zip-2.3-8vl1
statserial-1.1-20vl1
netpbm-9.9-3vl1
netpbm-progs-9.9-3vl1
net-tools-1.60-4vl1
ntp-4.1.0-0vl0
timetool-2.7.3-1vl1
nkf-1.92-0vl6
w3m-0.2.3.2-0vl1
irb-1.6.6-0vl4
pciutils-2.1.8-25vl1
gpm-1.19.3-0.6vl4
gdb-5.0-13vl2
ruby-1.6.6-0vl4
vine-logos-1.2.1-0vl2
timed-0.17-2vl1
control-panel-3.18-4vl2
inetd-0.16-7vl2
imlib-1.9.10-0vl2
libungif-4.1.0-9vl1
libtiff-3.5.5-8vl1
indexhtml-2.1-0vl8
kakasi-2.3.4-0vl1
screen-3.9.10-0vl1
tcp_wrappers-7.6-17vl0
unzip-5.41-3vl1
tmpwatch-2.6.2-2vl2
usbmgr-0.4.8-1vl1
utempter-0.5.2-4vl1
groff-1.16.1-0vl1
telnet-0.17.6x-18vl1
iputils-20001010-1vl4
hdparm-4.6-0vl1
openssh-server-3.0.2p1-0vl0
ImageMagick-5.2.9-0vl4
gated-3.6-5vl1
getty_ps-2.0.7j-12vl1
man-1.5i-10vl5
jman_pages-0.5-20011115vl1
kernelcfg-0.6-9vl1
pythonlib-1.28-1vl2
linuxconf-1.24r6-0vl3
mgetty-voice-1.1.25-5vl4
mgetty-1.1.25-5vl4
mgetty-sendfax-1.1.25-5vl4
mgetty-viewfax-1.1.25-5vl4
modemtool-1.22-3vl1
ncurses4-4.2-0vl1
netcfg-2.25-1vl2
openssh-clients-3.0.2p1-0vl0
redhat-release-6.2-1
samba-common-2.0.10_ja_1.2-0vl0
samba-2.0.10_ja_1.2-0vl0
samba-client-2.0.10_ja_1.2-0vl0
bootparamd-0.17-5vl3

-- 
 WWWWW  shibata@xxxxxxxx
 |O-O|  柴田 尚明@福岡市 一身上の都合により、また「ひげ」はえました
0(mmm)0 P-mail: 070-5419-3233    IRC: #luky
   ~    http://his.luky.org/ http://hoop.euqset.org/

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: