[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:050180] Re: sd_mod


中津井です。

On Tue, 7 May 2002 10:21:05 +0900
"simon" <simon _at_ lexues.co.jp> wrote:

> サイモンと申します。
> 
> 私も同じ現象です。
> 
> 何かよい対処法、お教えいただけないでしょうか。
> 
> ----- Original Message ----- 
> From: "Masaki Kawamura" <kawamura _at_ ic.sci.yamaguchi-u.ac.jp>
> To: "vine-users ML" <vine-users _at_ linux.or.jp>
> Sent: Wednesday, May 01, 2002 11:08 AM
> Subject: [vine-users:000006] sd_mod
> 
> 
> > こんにちは、かわむらです。
> > 
> > Vine Linux 2.5CR kernel-2.4.18 で、sd_modモジュールを
> > 読み込んだとき、そのままコマンドが停止します。
> > 
> > lsmodでみると、initializingと出ていますので、sd_modモジュール
> > の初期化の段階でループ(?)しているのではないかと思います。
> > 
> > 具体的にやったこと
> > デジタルカメラ Sony Cyber ShotをUSBで接続し、
> > mount /dev/sda /mnt/usb
> > などでマウントすると、そのまま固まります。C-cも効きませんし、
> > killでプロセスを停止できません。
> > Vine Linux 2.1.5 + テストパッケージの  kernel-2.4.16のときは
> > 正常に使用できました。
> > # ちなみに、kernel-2.2系ではうまくいっていません
> > 
> > 原因を調査したいのですが、デジタルカメラとの相性なのか、
> > sd_modモジュールの問題なのか良くわからないので、似たような
> > 症状があらわれた方はお知らせください。
> > 

FUJIFILMのFinePix 40i(2.4系kernelでusb-storageとして認識可能)
で同じような症状があらわれました。

このデジタルカメラは他のSCSIデバイスがない場合は/dev/sda1を
マウントすることができるのですが、ケーブルを挿入しても
/dev/sdaまでしか認識されません。

私のPCではuhciではなく、usb-uhciでないと正常に
USBを使えないようなのですが、VineLinux 2.5ではuhciがロードされていました。
そこで、まずusb-uhciをロードするようにしました。

それで、/dev/sda1をマウントすることができましたが、いったんunmountして
ケーブルを抜き、再度ケーブルを挿入したら、やはりsd_modが「initializing」
で止まってしまいます。

その状態で、自分でコンパイルしたlinux-2.4.18から起動してみると、
何度ケーブルを挿しなおしても正常に認識できるようになりました。

以上、報告を。

---
Masahiko Nakatsui
http://users.hoops.ne.jp/mas-works/
mas-fl _at_ jcom.home.ne.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: