[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:056164] Re: apt-get upgrade から外したいパッケージ


On 2002.11.25, at 16:50 Asia/Tokyo, Daisuke SUZUKI wrote:

> /etc/apt/apt.conf に hold 設定を追加すればいいです。
> 0.3.19 なら
> RPM
> {
>   HoldPkgs {"^postfix";};
> }
> というかんじで。
> すでに kernel が Hold 指定されていますので参考にするといいかとおもいます。
VinePPC2.6r1
apt-0.3.19.cnc.55-11vl4
な環境で/etc/apt/apt.confを編集したのですが、どうやってもpostfixがupgradeに引っかかってしまいます。
/etc/apt/apt.conf

**上記省略**
RPM
{
    // Leave list empty to disable
    AllowedDupPkgs {"^kernel$"; "^kernel24$"; "kernel-smp"; 
"kernel24-smp"; "kernel-enterprise"; "kernel-BOOT"; "kernel24
-BOOT"; "^kernel22$"; "^kernel22-smp"; "^mol-kmods$"; "^mol-kmods22$"; 
};
    HoldPkgs {"^kernel$"; "kernel-"; "^kernel24$"; "kernel24-"; 
"^kernel22$"; "kernel22-"; };
    HoldPkgs {"^postfix";};
}

や

{
    // Leave list empty to disable
    AllowedDupPkgs {"^kernel$"; "^kernel24$"; "kernel-smp"; 
"kernel24-smp"; "kernel-enterprise"; "kernel-BOOT"; "kernel24
-BOOT"; "^kernel22$"; "^kernel22-smp"; "^mol-kmods$"; "^mol-kmods22$"; 
};
    HoldPkgs {"^kernel$"; "kernel-"; "^kernel24$"; "kernel24-"; 
"^kernel22$"; "kernel22-"; "^postfix";};
}

も試しました。また「postfix-」「^postfix-」等も試したのですが、どうしてもapt-get 
upgradeでのpostfix登場を消すことが出来ません。

他に見るべき設定はあるのでしょうか?

ちなみにpostfixはsasl対応とした、postfix-1.1.11-0vl3です。srpmファイルは2.6のものを持ってきました。

--
++++++++++++++++++++++++++
須々木俊太(ススキ シュンタ)

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: