[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:056436] rpm を作ってみたのですが


福と申します。
いままでパッケージとかにあまり興味が無かったのですが、
同僚がopen-cobolを使ってみたいと言い出したのをきっかけ
にVINE用が見当たらなかったのでとりあえず見よう見真似で
rpmを作成してみました。

open-cobolそのものは添付のspecを使うと何の問題も無く
作成できました。(tar.gzとspecをそれぞれrpm/SOURCES,
rpm/SPECSにコピーしてrpm -ba open-cobol.spec)

gmpのバージョン3以上をopen-cobolが要求するので、gmp-4.1を
とってきてgmp-2.0.2用のspecファイルをちょこちょこっと
編集してrpmを作成してインストールしopen-cobolが動作する
ことまでは確認したのですが、apt-cache searchすると次の
ようなエラーが出ます。
apt-cache search gmp
E: There are two or more versions of the package 'gmp' installed in your system,
 which is a situation APT can't handle cleanly at the moment.
Please do one of the following:
1) Keep at most one version of the package in the system; or
2) If you do want to keep multiple versions of that package, lookup RPM::Allow-D
uplicated in the documentation.

E: Error occured while processing gmp (UsePackage3)
E: Problem with MergeList /var/lib/rpm/Packages

これはgmp-4.1とgmp-2.0.2の二つのパッケージが入っているのが原因だと
思われますが、gmp-2.0.2を消すこともできずに困っています。

このような場合はどのように対処するのが妥当なのでしょうか?
RPM::Allow-Duplicated in the documentation.とありますが、
どの文章を参照すればいいのでしょうか?ご指導よろしくお願いします。



-- 
Atsushi Fukushima 
mailto:atushi _at_ ss.iij4u.or.jp
Call:090-8116-6978

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: