[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:056695] j2re におけるglibcのバージョン


谷村と申します。

私もパッケージングの話ですが、本日javaアプレットを使用したWebを閲覧する必
要があり、j2re1.3.1を入れました。

j2re-1.3.1-FCSvl1.nosrc.rpm と、j2re-1.3.1-FCSvl1.nosrc.rpm の中の
j2re.spec に書かれていた
ftp://ftp.lab.kdd.co.jp/Linux/java-linux/JDK-1.3.1/i386/FCS/%{name}-%{version}-FCS-linux-i386.tar.bz2
から rpm を作成したのですが、いざでき上がった rpm を入れようとすると、
glibcが2.1.3じゃないからだめだと言われました。

私の環境には、glibc-2.2.4-14vl13 が入っています。仕方がないので、j2re.spec
の Requires: glibc = 2.1.3 を Requires: glibc >= 2.1.3 に書き換えて、再度
rpmを作成しインストールしました。

ここで質問なのですが、j2re は特有のバージョンの glibc が必要なものなのでし
ょうか、それとも今回の措置はこれでよかったのでしょうか。

現在のところ、java実行環境は正常に動いているように見えます。パッケージャー
の方にDM使用かとも思いましたが、ご負担になるかも知れないと思いMLに流すこと
にしました。

よろしくお願いします。

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」