[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:056980] Re: PHPを入れるとApacheが落ちる


伊藤です。

Mon, 16 Dec 2002 17:37:13 +0900に
Shiroma <cuptino _at_ ops.dti.ne.jp> さんは書きました。

> しろまですが。
> 
> 取りあえずphpとApacheのバージョン、Modのバージョン、
> そしてHttpdのエラーログ辺りを書いてみてはどうでしょうか。
> 
> Rubyとphpが両立しないってすごい不思議な現象のような気がします。
> その辺の真実はエラーログに書かれてはいないでしょうか。

バージョンは

    apache-1.3.27-0vl2  (VineLinux提供のRPM)
    php-4.2.3-0vl1      (VineLinux提供のRPM)
    eruby-1.0.0         (tar玉よりインストール)
        eruby-0.9.7.-0vl1 のVineLinux提供のRPM版も試しました
    mod_ruby-1.0.2      (tar玉よりインストール)
        mod_ruby-1.0.1-0vl1 のVineLinux提供のRPM版も試しました

です。エラーログなのですが、

    /etc/rc.d/inet.d/httpd start

で起動後にはいたログは何一つありませんでした。
起動後(モジュールロード中?)にそのままお亡くなりになったという
ところでしょうか?

と思ったのですが、httpd.conf

    LoadModule php4_module     modules/libphp4.so

のあとに

    LoadModule ruby_module     modules/mod_ruby.so

と書いていたのを、先に書くように変更してみたら、起動後いきなり
おちることはなくなりました。(でもPHPもRubyも動きません)
このときは、error_logに以下のように出力されました。

    [Mon Dec 16 17:52:36 2002] [notice] caught SIGTERM, shutting down
    ruby: warning: already initialized constant DECLINED
    ruby: warning: already initialized constant DONE
    ruby: warning: already initialized constant OK
    ruby: warning: already initialized constant HTTP_CONTINUE
    ruby: warning: already initialized constant HTTP_SWITCHING_PROTOCOLS
    ruby: warning: already initialized constant HTTP_PROCESSING
    ruby: warning: already initialized constant HTTP_OK
    ruby: warning: already initialized constant HTTP_CREATED
                             ・
                             ・
                             ・
    ruby: warning: already initialized constant REMOTE_NAME
    ruby: warning: already initialized constant REMOTE_NOLOOKUP
    ruby: warning: already initialized constant REMOTE_DOUBLE_REV
    ruby: warning: already initialized constant MOD_RUBY
    [Mon Dec 16 17:52:36 2002] [notice] Apache/1.3.27 (Unix)  (Vine/Linux) mod_ruby/
    1.0.2 Ruby/1.6.7 mod_ssl/2.8.12 OpenSSL/0.9.6b configured -- resuming normal ope
    rations
    [Mon Dec 16 17:52:36 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)

ちなみに、httpd.confにおけるphpがらみの記述はデフォルトのままですが、
mod_rubyに関しては、以下のように書いています。

    LoadModule ruby_module

    AddModule mod_ruby.c

    AddHandler ruby-script .rbx

    <IfModule mod_ruby.c>
            RubyRequire apache/ruby-run
            RubyRequire apache/eruby-run

            <Files *.rbx>
            SetHandler ruby-object
            RubyHandler Apache::RubyRun.instance
            RubyKanjiCode sjis
            RubySafeLevel 1
            </Files>

            <Files *.rhtml>
            SetHandler ruby-object
            RubyHandler Apache::ERubyRun.instance
            RubyKanjiCode sjis
            RubySafeLevel 1
            </Files>
    </IfModule>

他のログ等々、もうちょっと調べてみます。


-----
Asuka ITO <asuka _at_ pc-ad.com>

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
References: