[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:056991] Re: WindowMaker の効果音(L2キャッシュが認識されない)


長南です。

政さんのメールより [vine-users:056988]
> 
> kernel-2.4.19-0vl26あたりからi810_audioが動くようになったようですが、
> WindowMakerではイベントに関する処理(ウィンドウの開閉等)で全く音が
> 出なくなります。(xmms等は問題無し、又Gnomeでは全く問題無し)

これを読んで、半年ほど前の経験を思い出しました。
Vine 2.5 から Thinkpad i1800 は ALSA を使わないでも、i810_audio
で音が出るようになったのですが、WindowMaker の効果音が鳴りません
でした。WindowMaker は /usr/bin/wsoundplay で音を出しているよう
ですが、どうやら、i810_audio と wsoundplay の組み合わせでは、
ある種の wavファイルの再生がうまく行かないようなのです(サウンド
カードが SB 16 なんかだったら、問題なしだし、Vine 2.1.5 で ALSA
を使っていたときも問題なかった)。play で効果音を鳴らしてみると、
一応音がするものの、こんなふうになりませんか。

  $ play /usr/share/WindowMaker/Sounds/v-startup.wav
  sox: Sound card appears to only support singled word samples.\
       Overriding format
  sox: Sound card appears to only support 2 channels.  Overriding format

そこで、私は sox で wav ファイルを作り直してみました。

  $ sox v-startup.wav -w -c 2 v-startup2.wav
  (-w -c 2 などのオプションはよくわからないので、いい加減です。
   何が一番よいか、man sox で調べてください)

こうしてできた v-startup2.wav などは wsoundplay でも音が出ます。
あとは、v-startup2.wav などを ~/GNUstep/Library/WindowMaker/Sounds
に v-startup.wav などとしてコピー。~/GNUstep/Defaults/WMSound を
チェック。これで WindowMaker の効果音が鳴るようになりました。

以上の方法が、使えないでしょうか。私はまだ Vine 2.6 で試しては
いませんけれど。

いま気がついたのですが、「[vine-users:056955] i845 チップセットでの
サウンド設定について」も同じ問題かもしれませんね。

> WMSoundSetをsrc.rpmからrebuildしようとしたらエラーが出ちゃって現在
> 対策を考えてますが、もしかするとProjectの方々にパッケージングし
> なおしてもらわなきゃならないかもしれません。
 
WMSoundPrefs(効果音の設定) は Vine 2.5 で使えなかったのですが、
Vine 2.6 でも動かないみたいですね。私のところだけ?

--
長南洋一
cyoichi _at_ maple.ocn.ne.jp

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: